VERTICAAL ZOEKEN

Omschrijving van de functie

De functie VERT.ZOEKEN gebruik je voor het opzoeken van en verwijzen naar functies als je gegevens wilt zoeken in een tabel of bereik per rij. Deze formule lijkt op horizontaal zoeken. Het verschil is dat je bij verticaal zoeken waardes haalt uit een verticale tabel en bij horizontaal zoeken juist gegevens haalt uit een horizontale tabel.

De schrijfwijze van de functie VERTICAAL ZOEKEN is als volgt:

figuur 1

De functie VERT.ZOEKEN heeft de volgende argumenten:

Zoekwaarde

De zoekwaarde kan bestaan uit een waarde of een verwijzing naar een cel. De waarde die je wilt opzoeken, moet zich bevinden in de eerste rij van het celbereik

Tabelmatrix

Dit is het celbereik waarin met VERT.ZOEKEN wordt gezocht naar de zoekwaarde en de gezochte waarde.

De eerste kolom in het celbereik moet de zoekwaarde bevatten. Het celbereik moet ook de retourwaarde bevatten die je wilt zoeken.

kolomindex_getal   
page3image10069008
Vul het kolomnummer in (de meest linkse kolom in de tabelmatrix is kolom 1, de kolom daarna is 2, etc. ) waar de waarde staat waarin gezocht moet worden.
Benaderen
  • Je gebruikt de waarde “WAAR” als de eerste kolom in de tabel numeriek of alfabetisch is gesorteerd. Er wordt gezocht naar de meest overeenkomende waarde. Geef je niets op dan wordt deze methode uitgevoerd.
  • Gebruik je de waarde “ONWAAR” dan zoek je naar de exacte waarde in de eerste kolom.

Met de volgende stappen kun je deze formule zelf rechtstreeks in een cel schrijven:

  1. Kies een cel waar je het resultaat wilt tonen.
  2. Typ =VERT.ZOEKEN( om de formule te beginnen.
  3. Vul de zoekwaarde in.
  4. Typ ; (een puntkomma).
  5. Selecteer het cel bereik (de tabelmatrix) waar binnen je wilt zoeken.
  6. Typ ; (een puntkomma).
  7. Typ het kolomindex_getal.
  8. Typ ; (een puntkomma)
  9. Typ WAAR of ONWAAR.
  10. Sluit de formule met een ).

Voorbeeld

Je kan bijvoorbeeld de achternaam van een werknemer opzoeken op basis van het werknemersnummer of het telefoonnummer zoeken door de achternaam op te zoeken (net als in een telefoonboek).

Het geheim van VERT.ZOEKEN is om je gegevens zo te ordenen dat de waarde die je opzoekt (de achternaam van de werknemer) links komt te staan van de retourwaarde die je zoekt (telefoonnummer van de werknemer).

Je hebt bijvoorbeeld werkmap met gegevens (zie figuur 2).

figuur 2

In cel C10 gaan we nu de zoekwaarde neerzetten. In cel C11 moet dan de gevonden waarde te komen staan.

Om dat te bereiken zet je in cel C11 de volgende formule: =VERT.ZOEKEN(C10;B1:D8;3;ONWAAR)

In cel C10 zet je nu bijv. Gerard

Als retourwaarde krijg je dan “Zwolle”.

figuur 3

De formulebouwer

Je kunt er ook gebruik maken van de formulebouwer om de formule te schrijven.

Selecteer dan wederom cel C11 en klik in de formulebalk op ”fx”:

Zoek vervolgens op ”vert.zoeken” en klik op ”functie invoegen”.

  • Bij zoekwaarde voer je C10 in. Cel C10 wordt in dit voorbeeld namelijk de cel waarin je de zoekwaarde gaat typen.
  • Bij tabelmatrix selecteer je het gedeelte waarin je Excel wilt gaan laten zoeken, met andere woorden: het celbereik. In dit voorbeeld is het celbereik B1:D8 en niet A1:D8 omdat de eerste kolom de zoekwaarde moet bevatten. En omdat we in dit voorbeeld op naam gaan zoeken is de eerste kolom B.
  • Bij kolomindex_getal voer je het kolomnummer in waar de waarde staat waarin gezocht moet worden. Je wilt de woonplaats van Gerard opzoeken en de woonplaats staat in kolom D. Aangezien de tabelmatrix bestaat uit de kolommen B, C en D is in dit voorbeeld kolom D getal 3.
  • Je wilt de woonplaats weten, dit is een exacte waarde, daarom voer je bij benaderen ONWAAR in.
figuur 5

In cel C10 schrijf je nu ‘’Gerard’’. Als retourwaarde krijg je dan “Zwolle”. Verander je in cel C10 de naam in Piet, zal de retourwaarde veranderen in Maastricht.

Op deze manier kun je Excel dus snel gegevens voor je laten zoeken. Deze manier van zoeken kan veel tijd besparen als je een groot bestand hebt.

In figuur 6 zie je wat de formule eigenlijk precies doet.

Figuur 6

Excel zoekt binnen het celbereik in de eerste kolom (kolom B in dit voorbeeld) naar beneden (dus verticaal) tot Excel de zoekwaarde heeft gevonden die is ingevuld in cel C10. Daarna zoekt Excel naar de waarde in het kolomnummer dat is ingevuld bij kolomindex_getal (in dit geval kolom 3 en dus de woonplaats).

De functie “VLOOKUP” doet hetzelfde als de functie “Vert. ZOEKEN”. De functie VLOOKUP moet je gebruiken als je de Engelse versie van Excel gebruikt.

De schrijfwijze is dan:
=VLOOKUP(C10;B1:D8;3;FALSE) zodat ook nu “Zwolle” als resultaat wordt gegeven.

Vraag en antwoord

Vraag: Zoek in onderstaande tabel doormiddel van verticaal zoeken in welke provincie Floortje woont. De formule moet worden ingevuld in cel D12 en je moet vervolgens in cel D11 op een naam kunnen zoeken.

figuur 7