SOM ALS

Omschrijving van de functie

Met de functie SOM.ALS tel je getallen, cel-verwijzingen, cel-bereiken of een combinatie hiervan op, mits ze voldoen aan een bepaalde voorwaarde.

De schrijfwijze van de functie SOM.ALS is als volgt:

Figuur 1

Deze functie heeft meerdere verplichte argumenten:

Bereik Dit argument is verplicht. Hiermee geef je aan welke cellen bij elkaar opgeteld moeten worden.
Criterium Dit argument is verplicht. Hiermee geef je aan welk criterium moet worden voldoen om opgeteld te worden. Het criterium moet tussen dubbele aanhalingstekens worden getypt als het uit tekst bestaat of als er logische of wiskundige symbolen in staan.

Als het criterium alleen uit getallen bestaat zijn geen dubbele aanhalingstekens nodig.

Optelbereik Dit argument is optioneel. Hiermee geef je aan welke cellen mee moeten worden genomen in de berekening, die buiten het bereik vallen.

Met de volgende stappen kun je deze functie zelf rechtstreeks in een cel schrijven:

  1. Kies een cel waar je het resultaat wilt tonen.
  2. Typ =SOM.ALS(
  3. Typ of selecteer het cel-bereik.
  4. Typ ; (een puntkomma).
  5. Typ het criterium.
  6. Indien je het optelbereik wilt gebruiken typ je eerst een puntkomma, daarna typ je het optelbereik.
  7. Typ een ) om de formule af te sluiten.

Voorbeeld

Je hebt een werkblad (zie figuur 2) vol getallen die je bij elkaar wilt optellen:

Figuur 2

Je wilt echter alleen de getallen bij elkaar optellen die groter zijn dan 10.

In dit voorbeeld is het cel-bereik A1:E9.

En het criterium is >10 (groter dan 10).

De formule wordt in dit voorbeeld daarom: =SOM.ALS(A1:E9;’’>10’’)

Het criterium bevat het symbool >, daarom is het belangrijk dat je het criterium tussen dubbele aanhalingstekens typt.

figuur 3

In het tweede voorbeeld combineren we de functie SOM.ALS met de functie POS.NEG die in de vorige les is uitgelegd.

Stel je houdt bij in Excel hoeveel winst je per dag maakt. Je werkblad ziet er bijvoorbeeld zo uit:

Figuur 4

Zoals je ziet maak je op sommige dagen winst en op sommige dagen verlies. Met de functie SOM.ALS kun je Excel gelijk laten weergeven hoeveel dagen je winst en verlies maakt.

In cel B10 wil je het aantal winstdagen weergeven en in cel B11 het aantal verliesdagen.

In cel B10 vul je de formule =SOM.ALS(C2:C8;1) in. In cel B11 doe je hetzelfde, alleen dan verander je het criterium in -1.

Figuur 5

Nu wil je ook graag zien hoeveel winst en verlies je hebt gemaakt. In cel B13 wil je weergeven hoeveel winst je hebt gemaakt en in cel B14 hoeveel verlies.

Het bereik blijft C2:C8 en het criterium 1 (bij verlies -1). Alleen wordt nu het optelbereik eraan toegevoegd. Dit is cel B2 tot en met B8.

Figuur 6

De formulebouwer

Je kaner ook voor kiezen om gebruik te maken van de formulebouwer.

Stel je wilt een aantal cellen bij elkaar optellen. Je wilt echter alleen de cellen optellen met een waarde die hoger is dan 3.

Figuur 7

Selecteer de cel waar je de uitkomst wilt hebben en klik daarna op ‘’fx’’.

Zoek in de formulebouwer de functie SOM.ALS op en voeg deze functie in.

Het bereik is in dit voorbeeld (zie figuur 7 en 8) A1:A10 en het criterium >3 (groter dan 3). Je kunt het bereik zelf typen of door de gewenste cellen te selecteren.

Figuur 8

Klik daarna op ‘’gereed’’ en Excel telt alle waarden van cel A1 tot en met A10 op met een waarde hoger dan 3.

Figuur 9

Vraag en antwoord

Vraag: Een bedrijf heeft in meerdere steden in Nederland kantoren (zie figuur 10).

figuur 10

Tel met behulp van de functie SOM.ALS de winst op van alle kantoren met minimaal 2500 werknemers.