Leer hoe celverwijzingen werken in Excel

Een cel-verwijzing wijst naar een cel in je werkblad. Zo verwijst =B3 naar cel B3.

Een cel-bereik bestaat uit meerdere cellen. Zo verwijst =E5:E11 naar de cellen E5 tot en met E11.

Je kan ook verwijzen naar cellen op een ander werkblad. =Blad3!D1 verwijst bijvoorbeeld naar cel D1 op werkblad 3.

Excel maakt hierbij onderscheidt tussen relatieve en absolute cel-verwijzingen. In de meeste gevallen wil je gebruik maken van een relatieve cel-verwijzingen. Dit is dan ook standaard in Excel. Zodra je formules kopieert, zal Excel gebruik maken van relatieve cel-verwijzingen. In onderstaande tabel wordt duidelijk wat de verschillen zijn:

Type verwijzing Formule Resultaat na kopiëren
Relatief =B3 Kolomverwijzing (B) en rijverwijzing (3) veranderen mee.
Absoluut =$B$3 De kolomverwijzing en rijverwijzingen blijven B3.
Voorbeeld 1:
figuur 1

In cel E1 wil je cel A1, B1, C1 en D1 bij elkaar optellen. Je krijgt dan dus de formule =SOM(A1:D1)

Vervolgens wil je ditzelfde doen met de cellen E2, E3, E4 en E5. Dit doe je door de formule naar beneden te kopiëren.

figuur 2
figuur 3

En zoals je ziet heeft Excel de kolomverwijzing en rijverwijzing automatisch aangepast. Dit is een voorbeeld van een relatieve cel-verwijzing. Hier hoef je dus niets voor te doen, omdat dit de standaard is in Excel.

Voorbeeld 2:

Als je een dollarteken voor zowel de kolomverwijzing als de cel-verwijzing plaatst dan veranderd dit niet mee zodra je de formule naar beneden kopieert.

figuur 4

Zoals je ziet blijft nu som 16, omdat A1:D1 vast is blijven staan in de formule.

Dit is dus een absolute cel-verwijzing.

Je kunt relatieve- en absolute cel-verwijzingen ook combineren.

Formule Resultaat na kopiëren
=$B3 Kolomverwijzing B blijft gelijk maar rijverwijzing 3 verandert wel mee.
=B$3 Kolomverwijzing B verandert wel mee maar rijverwijzing 3 blijft gelijk.