Geneste ALS

Omschrijving van de functie

Een geneste ALS formule betekent dat je een ALS-functie gebruikt binnen een andere ALS formule. Hierdoor kun je verschillende criteria testen en het aantal mogelijke resultaten vergroten. In totaal kan je maximaal 64 ALS-functies gebruiken.

De schrijfwijze van de formule geneste ALS is als volgt:

figuur 1

Met de volgende stappen maak je de geneste ALS formule

  1. Selecteer de cel waarin je het antwoord wilt hebben
  2. Typ =ALS( om de formule te beginnen
  3. Typ de logische test (de voorwaarde)
  4. Typ een ; (puntkomma) om aan te geven dat het volgende argument volgt
  5. Typ tussen dubbele aanhalingstekens wat Excel moet doen als de eerste voorwaarde waar is
  6. Als de eerste voorwaarde onwaar is, dan moet Excel naar de volgende voorwaarde gaan. Deze begin je bij de Geneste ALS altijd met het typen van ALS(
  7. Typ de tweede voorwaarde, gevolgd door een ; (puntkomma)
  8. Typ tussen dubbele aanhalingstekens wat Excel moet doen als de voorwaarde van punt 7 waar is
  9. Indien er nog een ALS formule volgt moet je stap 6 t/m 8 herhalen.
  10. Aan het eind van de formule gebruik je de laatste juiste voorwaarde. Typ tussen dubbele aanhalingstekens wat Excel moet doen als de laatste voorwaarde juist is en typ wederom een ; (puntkomma)
  11. Typ tussen dubbele aanhalingstekens wat Excel moet doen als de laatste voorwaarde onjuist is
  12. Je moet een haakje aan het einde van de geneste ALS typen voor elke logische test die je hebt ingevoerd. Heb je 3 logische testen ingevoerd, typ je op het einde dus 3 haakjes.

De schrijfwijze van de geneste ALS kan best ingewikkeld overkomen. Ik hoop dat met onderstaand voorbeeld alles duidelijk wordt.

Voorbeeld

We gebruiken het zelfde voorbeeld als bij de ALS formule. Een bedrijf houdt in Excel bij hoeveel verkopen werknemers hebben gehad in een bepaalde periode.

figuur 2

In dit voorbeeld is de grootte van de bonus afhankelijk van hoeveel je hebt verkocht.

  • Onder de €2000 verkopen krijg je geen bonus
  • Meer dan €2000 verkopen is een bonus van €250
  • Meer dan €3000 verkopen is een bonus van €500
  • Meer dan €5000 verkopen is een bonus van €1000

We gaan nu stap voor stap deze formule schrijven in cel C2:

  1. Typ =ALS( om aan te geven dat de formule begint
  2. We gaan nu de eerste voorwaarde schrijven. We beginnen met het argument dat er bij meer dan €5000 verkopen een bonus is van €1000. Als we namelijk zouden beginnen met meer dan €2000 verkopen is een bonus van €250, dan denkt Excel bij €3902 dat het groter is dan €2000 en dus een bonus is van €250.
    Typ daarom B2>5000 (de voorwaarde is dus dat de celinhoud van cel B2 meer moet zijn dan 5000)
  3. Typ een ; (puntkomma) om aan te geven dat het volgende argument volgt
  4. Typ tussen dubbele aanhalingstekens wat Excel moet tonen als aan de voorwaarde van punt 2 wordt voldaan. Bij de voorwaarde groter dan 5000 willen we dat Excel de bonus van €1000 toont. Daarom typen we hier “€1000”
  5. Typ ;ALS( om aan te geven dat de volgende ALS formule begint
  6. De voorwaarde die nu komt moet door Excel worden berekend als er niet aan eerste voorwaarde (B2>5000) is voldaan. De voorwaarde is nu dat de inhoud van cel B2 groter moet zijn dan 3000. En kleiner dan 5000, want als de inhoud groter was geweest dan 5000 dan werd er al voldaan aan de voorwaarde van punt 2. Typ daarom B2>3000
  7. Typ een ; (puntkomma) om aan te geven dat het volgende argument volgt
  8. Typ tussen dubbele aanhalingstekens wat Excel moet tonen als aan de voorwaarde van punt 6 wordt voldaan. Bij de voorwaarde groter dan 3000 willen we dat Excel de bonus van €500 toont. Daarom typen we hier “€500”
  9. Typ ;ALS( om aan te geven dat de volgende ALS formule begint
  10. In het laatste gedeelte van de formule willen we aangeven dat je een bonus van €250 krijgt als je meer dan €2000 aan verkopen hebt. Typ daarom B2>2000
  11. Typ een ; (puntkomma) om aan te geven dat het volgende argument volgt
  12. Typ tussen dubbele aanhalingstekens wat Excel moet tonen als aan de voorwaarde van punt 10 wordt voldaan. Bij de voorwaarde groter dan 2000 willen we dat Excel de bonus van €250 toont. Daarom typen we hier “€250”
  13. Typ een ; (puntkomma) om aan te geven dat het volgende argument volgt
  14. Ten slotte moeten we aangeven wat Excel moet doen als er niet aan de voorwaarde wordt voldaan, met andere woorden als de voorwaarde niet groter is dan 2000. In dat geval willen we geen bonus. Typ daarom “€0”
  15. Om de formule juist af te sluiten moet je een haakje typen voor elke logische test die we hebben ingevoerd. In totaal zijn dat er drie (namelijk B2>5000, B2>3000 en B2>2000). Typ daarom )))

Als je vervolgens met de vulgreep de formule in cel C2 naar beneden kopieert, krijg je het volgende resultaat:

figuur 3

Vraag en antwoord

figuur 4

Vraag: een bedrijf houdt zijn bestelling bij in Excel. In onderstaand werkblad zie je een aantal bestellingen staan. De verzendkosten zijn afhankelijk van het gewicht van het pakketje.

Geef met behulp van de geneste ALS formule aan per bestelling hoe hoog de verzendkosten zijn.