ALS functie

Omschrijving van de functie

De functie ALS is een van de meest gebruikte formules in Excel. Dit wordt ook wel een logische functie genoemd.

Deze functie gebruik je als een berekening aan bepaalde voorwaarden is gebonden. Je laat Excel dan een bepaalde tekst of uitkomst van een berekening tonen als aan die voorwaarde wordt voldaan.

De schrijfwijze van de functie ALS is als volgt:

figuur 1

De functie ALS heeft de volgende argumenten:

Voorwaarde Hier voer je in wat de voorwaarde is waar aan moet worden voldaan.
Berekening als aan de voorwaarde wordt voldaan Hier voer je in wat er moet gebeuren zodra aan de voorwaarde wordt voldaan.
Andere gevallen Hier voer je in wat er moet gebeuren zodra er niet aan de voorwaarde wordt voldaan.

Met behulp van de volgende stappen gebruik je deze formule

  1. Selecteer de cel waarin je het antwoord wilt hebben.
  2. Typ =ALS( om de formule te beginnen
  3. Typ de logische test (de voorwaarde dus).
  4. Typ ; (een puntkomma)
  5. Typ tussen dubbele aanhalingstekens wat Excel moet doen indien aan de voorwaarde wordt voldaan.
  6. Typ ; (een puntkomma)
  7. Typ tussen dubbele aanhalingstekens wat Excel moet doen indien er niet aan de voorwaarde wordt voldaan.
  8. Typ het rechterhaakje ) om de formule af te sluiten en druk vervolgens op enter.

Voorbeeld

Stel je hebt een bedrijf waarbij de verkopers een bonus krijgen als ze voor meer dan een bepaald bedrag hebben verkocht.

In een tabel heb je alle personeelsleden met de daar bijhorende verkopen ingevoerd. Nu wil je snel zien of iemand recht heeft op een bonus of niet.

figuur 2

In dit voorbeeld heb je recht op een bonus als je voor € 3000 of meer hebt verkocht.

  • De voorwaarde is B2>=3000 (dus de waarde in cel B2 moet 3000 zijn of hoger)
  • Als de waarde in B2 aan de voorwaarde voldoet moet er “Ja” getoond worden.
  • Als de waarde in B2 niet aan de voorwaarde voldoet moet er “Nee” getoond worden.

De formule wordt in dit geval =ALS(B2>=3000;”Ja”;”Nee”)

figuur 3

De formulebouwer

Je kunt er ook voor kiezen om de formulebouwer te gebruiken. Selecteer de cel (in dit voorbeeld cel C2) en klik in de formulebalk op ”fx”.

figuur 4

Zoek vervolgens in de formulebouwer op ”ALS” en klik op ”Ok”.

Daarna vul je de argumenten in zoals eerder onder figuur 2 is besproken:

figuur 5

Klik op ”OK” om de functie in te voegen. Als je vervolgens met behulp van de vulgreep de formules naar beneden kopieert heb je direct in een overzicht wie er recht heeft op zijn bonus en wie niet.

figuur 6

Voorwaardelijke opmaak

Als je echter veel personeel hebt wil je nog sneller kunnen zien wie er een bonus verdient. Dit kan met behulp van de voorwaardelijke opmaak.

Stap 1: Selecteer eerst cel C2 tot en met C10 en ga daarna in het lint naar ”Start” en klik op ”voorwaardelijke opmaak”:

figuur 6

Stap 2: Klik vervolgens op “nieuwe regel”

Stap 3: Klik onder selecteer type regel op ”alleen cellen opmaken met”

figuur 7

Stap 4: Klik onder bewerk de regelbeschrijving op ”alleen cellen opmaken met bepaalde tekst”. Kies vervolgens voor bevat ”nee”. (zie figuur 7)

Stap 5: Klik op ”opmaak”.

Stap 6: Klik op het tabblad ”opvulling” en kies een kleur naar keuze uit. Ik heb voor rood gekozen:

figuur 8

Eventueel kun je het zelfde doen met de mensen die wel een bonus verdienen. Dan laat je bijvoorbeeld alle cellen die ‘’ja’’ bevatten groen opvullen door stap 1 t/m 8 te herhalen.

Nu is het helemaal duidelijk wie een bonus verdient.

figuur 9

Vraag en antwoord

Vraag: een bedrijf houdt zijn bestelling bij in Excel. In onderstaand werkblad zie je een aantal bestellingen staan. De verzendkosten zijn gratis vanaf €30, anders zijn de verzendkosten €4,95

figuur 10

Geef met behulp van de formule ALS aan per bestelling hoe hoog de verzendkosten zijn.