ALS FOUT

Omschrijving van de functie

Het overkomt iedereen weleens dat Excel aangeeft dat je ergens een fout hebt gemaakt.

Vaak komt dit omdat bepaalde gegevens nog niet zijn ingevoerd.

Excel ziet bijvoorbeeld lege cellen als een 0. Als je dan bijvoorbeeld een cel-verwijzing laten delen door een cel die nog niet is ingevuld krijg je een foutmelding omdat je getallen niet door 0 kan delen.

figuur 1

Dit soort fouten kun je verbergen met de functie ALS.FOUT

De schrijfwijze van de functie ALS.FOUT is als volgt:

figuur 2

Deze functie heeft de volgende argumenten:

Waarde Hier kan je een waarde, celverwijzing of formule invoeren die je Excel wilt laten uitvoeren.
waarde_indien_fout: Hier kun je een willekeurige waarde of tekst of verwijzing

invoeren die getoond moet worden indien Excel een foutmelding geeft als het eerste argument niet kan worden uitgevoerd.

Met de volgende stappen kun je deze functie zelf rechtstreeks in een cel schrijven:

  1. Selecteer een cel waar je de uitkomst wilt tonen
  2. Typ =ALS.FOUT( om de formule te beginnen
  3. Typ een waarde, celverwijzing, formule of een som die uitgevoerd moet worden
  4. Typ een ; (puntkomma) om aan te geven dat het volgende argument volgt
  5. Typ tussen dubbele aanhalingstekens de tekst die moet worden getoond als er een foutmelding volgt als het eerste argument niet uitgevoerd kan worden
  6. Typ een ) om de formule te sluiten

Voorbeeld

In plaats van dat je in cel A3 =A1/A2 neerzet, ga je gebruik maken van de formule ALS.FOUT.

In cel A3 vul je nu in =ALS.FOUT(A1/A2;”Gegevens zijn nog niet compleet”)

Dit houdt in dat als in cel A3 een foutmelding komt omdat de som niet kan worden uitgevoerd, er nu komt te staan: Gegevens zijn nog niet compleet.

figuur 3

Kan de som wel worden uitgevoerd, omdat in dit voorbeeld in zowel cel A1 als in cel A2 een waarde staat, dan komt gewoon het resultaat van de som in cel A3:

figuur 4

De formulebouwer

Hoewel dit geen complexe formule is, kan je indien gewenst ook de formulebouwer gebruiken om deze formule te maken.

Selecteer daarvoor de cel waarin je de uitkomst wil tonen en klik in de formulebalk op ”fx”.

In het voorbeeld van zojuist selecteren we cel A3:

Figuur 5

Vervolgens zoek je in het venster dat wordt geopend op de functie ”ALS.FOUT” en klik op ”functie invoegen”.

Bij waarde vul je in wat Excel moet berekenen, in dit geval willen we cel A1 delen door cel A2. Daarom typ je hier A1/A2

Indien Excel bij deze berekening een foutmelding geeft, vullen we bij het tweede argument in wat Excel moet tonen:

figuur 6

Klik vervolgens op ”gereed”.

Vraag en antwoord

Vraag: er zijn 35 reizigers en je wilt berekenen hoeveel reizigers er per auto moeten. Daarvoor wil je dus het aantal reizigers delen door het aantal auto’s.
Je hebt de som al gemaakt, alleen is nog niet bekend hoeveel auto’s er beschikbaar zijn.Geef met behulp van de functie ALS.FOUT aan dat de gegevens nog niet bekend zijn en zodra deze wel bekend zijn de som alsnog wordt uitgevoerd.

figuur 7